cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JackieZhu
Frequent Visitor

Stop flow to automatically adding apply to each

Hi There,

 

I followed exactly what this instruction does. Everything work fine until I am reaching the last step to send email with options. I notied this apply to each 2 is automatically generated when I input dynamic field "title".

 

Anyone can help? Thank you so much!

 

https://flow.microsoft.com/es-es/blog/multiple-attachments-single-email/

 

Untitled.png

1 ACCEPTED SOLUTION

Accepted Solutions

HI @JackieZhu 

I see you are triggering the flow using the For a Selected Item trigger. The next action you used is "Get Items" are you trying to get mulitple items? If not, I would suggest you to remove the get items action and put the get item action over there. The "value" that is coming up and creating the apply to each loop is because the action Get Items returns a List of items in an array and if you just want to get a particular item, you must use Get Item action. 

 

Hope this Helps!

View solution in original post

4 REPLIES 4
yashag2255
Dual Super User II
Dual Super User II

Hi @JackieZhu 

 

I see that in the last action (send email with options) you are trying to input the title from the dynamic selector and looks like this is coming from a List of sharepoint items/ attachments. Can you post a screenhot of the entire flow so that we can assist you better? 

 

Thanks, 

Hi yashag2255!

 

Thanks for replying. Please see below for my full flow. Bacially this flow is designed to get approvals from people. The requestor will need to create a list on sharepoint and this list will send to approvor to approve/reject. There will also be multiple attachments. So I followed the instruction above to do it.

 

Here is the full list of my flow:

 

When I enter any dynamic seletction (e.g "title") in "send email with option" step, it will automatically add step "apply to each 2“. Also "value" is automatically added as well. Not sure why this is happenning...

 

 

1.JPG捕获.JPG

HI @JackieZhu 

I see you are triggering the flow using the For a Selected Item trigger. The next action you used is "Get Items" are you trying to get mulitple items? If not, I would suggest you to remove the get items action and put the get item action over there. The "value" that is coming up and creating the apply to each loop is because the action Get Items returns a List of items in an array and if you just want to get a particular item, you must use Get Item action. 

 

Hope this Helps!

View solution in original post

Hi @yashag2255 ,

 

This helps! I changed it to "Get Item" and now it's wokring perfect.

 

Thank you for your effort and time on this!

 

Jackie

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,460)