cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
T-Rex
Level: Powered On

PowerApp in Webpart Shifts Left

Looks like i may have found a bug in the PowerApps Webpart.  My embedded app (configured for iPhone) shifts left, leaving a black bar to the right, after changing any selected value in any combo boxes on the screen.  Initial selection causes no issues, but once a combo box with data is clicked on to change its value, the app shifts left, cutting off the left side.  Anyone else having this issue or have an idea how to fix it?

sscreencap.png

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
PowerApps Staff cherie
PowerApps Staff

Re: PowerApp in Webpart Shifts Left

Can you check if you have the sharepoint site in your trusted sites in internet explorer? 

 

If it is, can you either remove it, and try it again? Or if you don't want to remove it, can you add the url that you are attempting to launch and web.powerapps.com?

 

Thanks

Cherie

View solution in original post

12 REPLIES 12
PowerApps Staff cherie
PowerApps Staff

Re: PowerApp in Webpart Shifts Left

@T-Rex, when you mention web part, you mean the sharepoint web part?

 

Is it happening on a specific browser? Or across all?

 

Could you collect a session id for us to take a look?

 

Thanks

Cherie

T-Rex
Level: Powered On

Re: PowerApp in Webpart Shifts Left

Hi @cherie,

 

I'm seeing this particular issue in IE11 (Our company doesn't use Edge).  Additionally I have an image I'm usinig as a button with the OnClick Property using the Launch() function to open a URL in the browser.  This also doesn't work in IE.  Session ID: 2258c3aa-74f8-4ace-9b74-29d11e5cfd03
PowerApps 3.18102.

 

In Chrome, whenever I click a combo box control, the app jumps back to the top of the page, providing a less than ideal user experience.  No problem with the black bar or the launch function.  Session ID: 8de7c808-9996-4e94-b69f-95e2d0d3afce
PowerApps 3.18102.22

 

In Firefox I get This App isn't working, refresh your browser or try again later. and a Session ID: d4435ccd-9e1b-4a39-ae68-367ba76115b1.

PowerApps Staff cherie
PowerApps Staff

Re: PowerApp in Webpart Shifts Left

@T-Rex, I've asked a few of my colleagues to take a look at the issues you are seeing in Chrome and IE.

 

With regards to the Firefox issue, I believe we have a fix in the pipeline that will be deploying next week. I'll let you know when this deployment is complete and you can give it a try.

 

Thanks!

Microsoft Employee

Re: PowerApp in Webpart Shifts Left

Hi @T-Rex,

 

Can you please clarify what the issue is that you're seeing with Launch() in IE? I just tested this out and the only potential issue I encountered is that IE blocks the creation of a new tab or window by default and this behavior needs to be enabled. Can you please check to see if the pop up blocker is enabled?

 

Thanks,

Michael

T-Rex
Level: Powered On

Re: PowerApp in Webpart Shifts Left

Hi @Michael 

When I click on the image in the app that has the OnClick property set to use the Launch() function, nothing happens.  Note this only happens in IE11, in the PowerApps Web Part, on a SharePoint page.  It doesn't happen in the browser in Dynamics, the iOS App or in the browser during testing/playback in the development client.  I verified that my Pop-up blocker is off.

 

Thanks,

 

Rex

PowerApps Staff cherie
PowerApps Staff

Re: PowerApp in Webpart Shifts Left

Can you check if you have the sharepoint site in your trusted sites in internet explorer? 

 

If it is, can you either remove it, and try it again? Or if you don't want to remove it, can you add the url that you are attempting to launch and web.powerapps.com?

 

Thanks

Cherie

View solution in original post

T-Rex
Level: Powered On

Re: PowerApp in Webpart Shifts Left

That did it.  I added the link to Trusted sites. Thanks @cherie!

AG1
Level: Power Up

Re: PowerApp in Webpart Shifts Left

Hi,

Im having the same issue:

- IE11

- Happens after dropdown selection

- I unlocked aspect ratio and it seemed to stop shifting left but the form would auto scroll up or down after selection

- PowerApp is in a SharePoint page via a webpart

 

I'd like to make it available to many others, but I wouldnt want to have a disclosure to ask people to add to trusted sites. 

 

Please let me know of other solutions.

 

Thanks!

PowerApps Staff cherie
PowerApps Staff

Re: PowerApp in Webpart Shifts Left

The trusted sites issue should only be applicable if you are using the launch function. It doesn't seem like you are, is that correct?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,096)