cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
max81
Level: Powered On

Reuse code with toggle button

Hello together, hello @iAm_ManCat,

 

I'm reffering on this discussion:

https://powerusers.microsoft.com/t5/ .... /Call-code-easy-way-to-reuse-code  

and on this Video:

Youtube Video by Todd Baginski

 

I have problems using this "function" (global variable with toggle button) in Internet Explorer and Edge: In the simulation mode it works, but if I open the App without developing mode, it doenst work.

Also on my iPhone it doesn't work.
In Chrome it works well.

 

The variable is changed, but the toggle button is not "updated" until the screen with the toggle button is getting visible.

I'm confused if I'm the only one with this problem(?).

 

Thanks and best regards,

Max

1 ACCEPTED SOLUTION

Accepted Solutions
max81
Level: Powered On

Re: Reuse code with toggle button

@iAm_ManCat @ToddBaginski :

 

Just found this information under another video from Todd:


Trading emails with the PA team about this. I have been provided a workaround for the web player. The workaround is to add a reference to the toggle control on the pages where the toggle control does not exist. To do that easily you can add a label, make it invisible, and set the text property to tglErrorGlobal.Value. I did this and it worked well. Waiting to hear if this is a temporary workaround or not.

For me, the workaround worked.

View solution in original post

3 REPLIES 3
Highlighted
Super User
Super User

Re: Reuse code with toggle button

Hi @max81,

 

Ah, this used to work in all browsers.. I can confirm that it now does not work for IE/Edge for me either. I can trigger the toggle from another screen, but I have to navigate to the screen that the toggle is on to trigger it [except for in Google Chrome].

 

My initial thought is that it's to do with how the browser is loading the screens and their contents into memory, that the actions are suspended until the screen is visible & the object is loaded into memory & rendered.

 

@ToddBaginski have you noticed that the toggle remote trigger stopped working in IE/Edge?

I was pretty sure this used to work with all browsers.

 

Cheers,

Sancho




Don't forget to 'Mark as Solution' if a post answered your question and always 'Thumbs Up' the posts you like or helped you!
max81
Level: Powered On

Re: Reuse code with toggle button

@iAm_ManCat @ToddBaginski :

 

Just found this information under another video from Todd:


Trading emails with the PA team about this. I have been provided a workaround for the web player. The workaround is to add a reference to the toggle control on the pages where the toggle control does not exist. To do that easily you can add a label, make it invisible, and set the text property to tglErrorGlobal.Value. I did this and it worked well. Waiting to hear if this is a temporary workaround or not.

For me, the workaround worked.

View solution in original post

max81
Level: Powered On

Re: Reuse code with toggle button


@ToddBaginskihave you noticed that the toggle remote trigger stopped working in IE/Edge?


by the way: also my iPhone / iPad had this problem!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,082)