cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
forcedLightning
Advocate I
Advocate I

Display Form displays data and 'no data source' at the same time

I'm not sure how I managed to make this happen, but here's my predicament. 

 

I have a display form showing an item selected in a gallery pulling from a SharePoint list. The Display Form is based on Gallery1.Selected, and will no longer receive only my list as the source because the gallery has an AddColumns formula for filtering. So, I have the source as Gallery1.AllItems, and the item as Gallery1.Selected. It all works perfectly, except that the Display form seems to be confused now, as it displays the "This form isn't connected to any data yet" underneath it displaying data (see attached image).

 

For now it's merely an annoyance, but is there any way to remedy this? Am I doing something wrong?

1 ACCEPTED SOLUTION

Accepted Solutions

@mdevaney , @eka24, and @forcedLightning

Since he is using AddColumns in the Items property of his gallery, he cannot use Gallery.Selected in the form.

That being said, I just remembered another way to get past this. In this approach, you can still set your data source for the form to the actual data source and not Gallery.AllItems.

For the Item property of the form, use:
LookUp(DataSource, UniqueID = Gallery.Selected.UniqueID)

Then your Item property and the datasource of the form are in sync. And your form will not show this error either. It will all work smoothly.

---
If you like this reply, please give kudos. And if this solves your problem, please accept this reply as the solution.

Thanks!
Hardit Bhatia
https://thepoweraddict.com

View solution in original post

4 REPLIES 4
mdevaney
Super User
Super User

@forcedLightning
Can you please show your code?

What form property are your putting each of Gallery1.AllItems and Gallery1.Selected in?
eka24
Super User
Super User

Hello. The items property of the form should point to the Gallery as you have done. But your form datasource should point to the sharepoint list Name

If you like this post, give a thumbs up. Where it solved your issue, Mark as a solution
PowerAddict
Super User
Super User

That's a perfectly fine approach that I have used in the past for similar reasons as yours. Also, the form seems to show this as the datasource provided to the form isn't a "standard connection" (for the lack of a better phrase).
My question is: do you see this only while in the editor or do you see that even when the app is saved, published and played?
If the editor shows this but the app runs fine in the play mode (which is what happens to me), you should be good.

---
If you like this reply, please give kudos. And if this solves your problem, please accept this reply as the solution.

Thanks!
Hardit Bhatia
https://thepoweraddict.com

@mdevaney , @eka24, and @forcedLightning

Since he is using AddColumns in the Items property of his gallery, he cannot use Gallery.Selected in the form.

That being said, I just remembered another way to get past this. In this approach, you can still set your data source for the form to the actual data source and not Gallery.AllItems.

For the Item property of the form, use:
LookUp(DataSource, UniqueID = Gallery.Selected.UniqueID)

Then your Item property and the datasource of the form are in sync. And your form will not show this error either. It will all work smoothly.

---
If you like this reply, please give kudos. And if this solves your problem, please accept this reply as the solution.

Thanks!
Hardit Bhatia
https://thepoweraddict.com

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (1,596)