cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gilmara
Advocate I
Advocate I

ServerException adding screen

Unable to add a screen on a canvas app. Receiving ServerException occurred on server message. Tried different browsers and different user accounts. Other apps are fine, so it seems to be isolated to a single app. Any help is appreciated. 

1 ACCEPTED SOLUTION

Accepted Solutions
yashag2255
Dual Super User II
Dual Super User II

@gilmara 

 

Looks like the app is corrupted, you can copy paste all the controls at once to the new app.

 

If your issue is resolved, please mark the thread as solved so that it will be helpful for others as well.

 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

5 REPLIES 5
JayMagness
Solution Specialist
Solution Specialist

I would do the following:

 

1) save your program

2) close all down and restart the computer

3) reopen the application in edit mode and see if you can edite the screen then. (Do not restor last browser session).

 

Thanks, I did try that. No change. Also learned that I actually can't add any elements to any screen now. Icons, media, etc. Tried restoring to last version from Friday before I started making any changes today and same issue. Something has definitely became corrupted. Just hoping I can fix soon as we are launching this app to entire company by end of month. 

yashag2255
Dual Super User II
Dual Super User II

Hi @gilmara 

 

Can you please try to create a copy of the same application and verify the behavior?

 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Thanks @yashag2255 (I've ran across several of your tips and tricks). Yep, tried that too and tested the copy with different browsers and accounts also, no improvement. Luckily, I can copy paste, so I started a new app and was able to copy paste the whole thing back together. New version is working fine. Just have to make some X, Y tweaks. Going to gather this was just a corrupted app somehow. 

yashag2255
Dual Super User II
Dual Super User II

@gilmara 

 

Looks like the app is corrupted, you can copy paste all the controls at once to the new app.

 

If your issue is resolved, please mark the thread as solved so that it will be helpful for others as well.

 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (3,855)