cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate III
Advocate III

SubmitForm function can only work on a form. Wrong kind of control input is given...

All of a sudden, the Submit button stops working, producing this error:

 

paerror.png

 

It was working fine and I changed NOTHING in my EditForm.

 

This is a custom button. The original tick in the upper right corner with exactly the same formula/settings works just fine.

 

Any idea?

55 REPLIES 55
Highlighted
Regular Visitor

Yes, I am facing the same issue. 😞 hopefully it will be resolved soon

Highlighted
Advocate IV
Advocate IV

 I received word from Microsoft about this issue.  Unfortunately, there's no date yet, but they said:

 

Product team is working on high priority to get the issue fixed soon.

I will keep you updated.

Highlighted
Frequent Visitor

I have a button that does all 3, so I believe the Edit, New and ResetForm functions are all malfunctioning.

 

I have two miscrosoft accounts in my org, so i triggered the error when I transferred my working app from one environment, to the next as a brand new application.  Good thing I checked the board right away!  I was about to spend hours trying to troubleshoot this.

If i find a quick work around i'll respond.  (I dont think changing your functions to Patch is the sexiest idea tbh, so Ill have that be my last resort).

Highlighted
Frequent Visitor

When I moved my button out of its DataCard and pasted it on the main screen the function worked again. Pasted the same button into a DataCard in my form... error returned. Same happened with an icon.

 

Hope this info helps.

Highlighted
Frequent Visitor

Same issue for me... and bad luck, the customer is testing many of my powerapps list forms... Snif.. think I hate recent powerapps updates: issues with requestHide, now SubmitForm.. next week, another regression? QA required please

Highlighted

Just wanted to add that I'm also running into the same issue with the SubmitForm. Other functions that also worked previously in version 3.19061.14 (Patch and Running a Manually Triggered Flow) are also affected due to a mix of the variables being changed. For example, the "Modified" field is no longer there, it may have been replaced with "Updated"?  This is a PowerApps with a SharePoint List.

 

Other functions broken after 3.19062.18 releaseOther functions broken after 3.19062.18 release

 

 

Highlighted
Power Apps
Power Apps

Thanks for all of the reports on this issue! We've released a fix and this should be resolved now.

Highlighted

Knew you would!
Highlighted

Thanks for the update, much appreciated.
Highlighted
Anonymous
Not applicable

Thank you!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (3,128)