cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Harmanpreet
Level: Powered On

Custom Connector : Issue in swagger file

Hello,

 

I created a customer connector from blank and submitted for certification. I didn't create any swagger file on my end. So, downloaded the one from the connector in MS flow section and submitted for approval.  The whitelist URLs are also setup in the backend. But while testing on flow end they say that the URL are not whitelisted as they try to create the custom connector using the swagger file send from my end.

 

Please specify if something is missing while creating the custom connector or if any other changes reguired.

 

Thanks

Harmanpreet Kaur

1 REPLY 1
Jay-Encodian
Level 8

Re: Custom Connector : Issue in swagger file

Hi @Harmanpreet,

I'd personally recommend adding a swagger desicription to your API, as this would improve your ALM process. As you update your connector the swagger defintion would always be up to date preventing any sync issues... you can also add versioning, etc. 

Example: https://api.apps-encodian.com

The flow team were fantastic helping us through the submission process, they're probably your best route to progress if there are issues with your swagger file.

HTH

Jay

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 104 members 5,305 guests
Please welcome our newest community members: