cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mila
Helper II
Helper II

SharePoint List Remains Blank When A New Form is Submitted, While Flow Runs Successfully

Hi All,

 

I have created a flow, which runs successfully, an which has the objective of transferring the data harvested through an MS Form into a SharePoint list.

 

Mila_0-1598557159514.png

 

Throughout the day, I have had all sorts of errors, including the 'string date/time' error.

The latest, and the one that keeps recurring, is that the flow runs successfully and yet my list in SharePoint is empty, with only the Title field being populated.

 

I have rebuilt that list 4 times (at some point today it would not let me import it from Excel, despite having worked ok all morning) and I am at the end of my rope. 

 

Can anyone help?

 

Thanks!

 

25 REPLIES 25

@Mila 

 

i followed your logic and created test. i have created two date question in my MS form 1. DOB (required) 2. Visa Expiry (Not required).

and in SharePoint list made same column type.

 

Use this expression in each create item column for which date is optional-

if(empty(outputs('Get_response_details')?['body/r6ff84fef86f6418eba18cee1bba15ec9']),null,outputs('Get_response_details')?['body/r6ff84fef86f6418eba18cee1bba15ec9'])

This (outputs('Get_response_details')?['body/r6ff84fef86f6418eba18cee1bba15ec9']) is my dynamic value of Visa expiry date from dynamic content.

 
 

121.jpg

 

Thanks

Hardesh

So sorry @Hardesh15 , I tried but this doesn't work.

 

Mila_0-1598629850568.png

I have now updated the MS Form and deleted the date/time questions, and rebuilt them as single line text so that I can move on with the process. 

 

Thank you SO much for trying to help me!

@Mila 

 

Actually i pasted wrong screen. So i edit my last post. this will definitely work. i tested it.

use this kind of expression in your create item date column-

if(empty(outputs('Get_response_details')?['body/r6ff84fef86f6418eba18cee1bba15ec9']),null,outputs('Get_response_details')?['body/r6ff84fef86f6418eba18cee1bba15ec9'])

Thanks

Hardesh

@Mila 

 

Its simplified version of the same-

Hardesh15_1-1598630675105.png

 

Thanks

Hardesh

 

THANK YOU!! 

 

This has now worked for me!! 

 

Thanks so much for your help @Hardesh15 - you're a legend!

 

 

Thank you a lot @Mila and @Hardesh15 ! You also helped me a lot. I had the same problem with my flow, but now it is working perfectly!

 

Regards,

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (1,515)