cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Approval flow condition not firing (Might be a setting??)

Hi, 

 

I have been working on a simple approval flow that will send out an email and update a list once completed. I have been testing this flow and the condition always is coming up as false (When running it states not specified. Once I select approve in the email it states expression result: false)  This results in all items being rejected. Please see screenshots below. I appreciate your help!!!

 

Regards,

 

Maciej

 

 

 

Flow1_Inked.jpg

 

flow 3.PNGFlow2.PNG

1 REPLY 1
Highlighted
Community Support
Community Support

Re: Approval flow condition not firing (Might be a setting??)

Hi @Maciej_Nosek,

 

I have made a test on my side and don't have the issue that you mentioned.

The screenshot of the flow as below:

Capture.PNG

 

The flow would run successfully as below:

Capture.PNG

I afraid that the Value in your Condition "Approve" maybe have space in it

Please make sure the Value in the Condition is "Approve" and don't have space in it.

 

Also you could Edit the Condition in advanced mode, and the expression of the Condition should be as below:

Capture.PNG

Capture.PNG

 

@equals(body('Start_an_approval')?['response'], 'Approve')

Please let me know if your problem could be solved.

 

Best regards,

Alice

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (5,423)