cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

App will not close after Patch

I'm trying to get the application to close after patching but it just stays open: 

If(SPForm.Mode = FormMode.New,
    Patch(
        ParentList,
        Defaults(ParentList),
        {
            Title: formTitle.Text, 
            child: ForAll(ChildSelector.SelectedItems,{       '@odata.type':"#Microsoft.Azure.Connectors.SharePoint.SPListExpandedReference",
                Id: ID, 
                Value: Title 
                })
        }
    ); ResetForm(SPForm);RequestHide(),
    Patch(
        ParentList, 
        SharePointIntegration.Selected, 
        {
            Title: formTitle.Text, 
            child: ForAll(ChildSelector.SelectedItems,{       '@odata.type':"#Microsoft.Azure.Connectors.SharePoint.SPListExpandedReference",
                Id: ID, 
                Value: Title 
                })
        }
    ); ResetForm(SPForm);RequestHide();
);
ResetForm(SPForm);RequestHide()

 

26 REPLIES 26
Community Support
Community Support

Hi @simkessy ,

Could you please share a bit more about your issue?

Do you mean that the RequestHide() function could not close the Custom form in your SP List?

 

Based on the issue that you mentioned, I have made a test, and the issue is confirmed on my side. The RequestHide() function could not hide the custom form in SP list.

 

I would post this issue to my product team, if the issue is solved, I would reply here.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yes, that's exactly what I mean. When I hit the button to close it remains open.

 

We have the same issue with our custom form in
a SharePoint list. Requesthide() is not closing the form after successful submit

Hey @RandyHayes  any ideas on this one?

 

@simkessy 

Unfortunately, it appears that a new bug has crept into the picture...I am seeing the same issue. 

Team needs to resolve this one.  @Anonymous 

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!

Ah cool, thanks Randy. Glad I'm not crazy

 

 

Frequent Visitor

We're having the same issue with our form, the form submits the item to the SP list and then resets, but the RequestHide() function doesn't work, so the form remains open after submitting.  It's actually rather annoying, as we have a fairly large user base that interact with these forms and they have inadvertently sent duplicate submissions because they have thought that the form didn't submit properly.  

 

We're trying to communicate the issue out to our users and we're exploring alternative solutions in the meantime, but does anyone know a time table on how long it may take the product team to push a hotfix through for this issue?

Is this a new issue in your form? 

 

Yes, it was working great up until last Friday when we first noticed the issue.  I tried a bunch of different workarounds based on things I found online.  I created a new SP list and a new form, and found that the default Sharepoint form worked fine, it was only when I changed the form to a custom PowerApps form that the issue presented itself.  

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (31,732)