cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

IPad Patch & Submit Submits Default on first Button OnSelect

When submitting data via button onselect method, everything works fine on the Web. When using an IPad, the default form information is submitted, but submitting a second time works fine. When using an IPhone, everything works fine. What is going on? For some reason the form information is reset somehow.

 

OnSelect Code:

If(Connection.Connected,SubmitForm(NewScoreCard),Collect(LocalSafetyDataToPost,{Submitted_x0020_By:DataCardValue6.Text,Week_x0020_Ending:Text(WeekEndingDate.SelectedDate,DateTimeFormat.ShortDate),Days_x0020_Worked:DaysWorkedDropdown.Selected.Value,Shift_x0020_Meetings:ShiftsDropDown.Selected.Value,Safety_x0020_Meetings:SafetyMeetingDropdown.Selected.Value,Intervention:InterventionDropDown.Selected.Value,Intervention_x0020_Date:Text(DatePicker1.SelectedDate,DateTimeFormat.ShortDate),Inspection:Dropdown1.Selected.Value,Inspection_x0020_Date:Text(DatePicker2.SelectedDate,DateTimeFormat.ShortDate)});SaveData(LocalSafetyDataToPost,"LocalSafetyDataToPost")); Navigate(Success,ScreenTransition.Fade)

 

Example Default DataCard information:

If(NewScoreCard.Mode=FormMode.Edit,MySubmissions.Selected.Week_x0020_Ending,DateAdd(Today(),7-Weekday(Today(),Sunday),Days))

 

Form item:

If(NewScoreCard.Mode=FormMode.Edit,MySubmissions.Selected)

 

Gallery control to change form to Edit Mode:

Navigate(Scorecard,ScreenTransition.Fade); EditForm(NewScoreCard)

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

I talked with my colleagues and this seems to be a known bug that we are planning to release a hot fix for it. Meanwhile, seems that you created the app in both 650 and 660 version. You should be able to go to the portal and temporary revert the app to a previous version until the hotfix is released.

 

Let me know if that fixes your problem

 

Thanks

View solution in original post

6 REPLIES 6
Highlighted
Power Apps
Power Apps

hi,

 

Could you please check the versions of PowerApps that you have on IPhone and IPad. Would be also great if you can share your session Id. you can get it by going to menu under session details.

 

Thanks

Reza

 

Highlighted
Frequent Visitor

Hi Reza,

 

Both are the same version: 2.0.661

 

Session ID on IPad = 0e2fb147-03f1-8396-140f-e4cf123a9b84

Session ID on IPhone = 8193926d-ed4c-97bb-1941-71a0d5d9f8f0

 

The app was created in IPad template.

Highlighted

Thanks a lot. We are investigating this. Will update here as soon as I find some answer.

 

Thanks

Reza

 

Highlighted

I talked with my colleagues and this seems to be a known bug that we are planning to release a hot fix for it. Meanwhile, seems that you created the app in both 650 and 660 version. You should be able to go to the portal and temporary revert the app to a previous version until the hotfix is released.

 

Let me know if that fixes your problem

 

Thanks

View solution in original post

Highlighted
Frequent Visitor

I have corrected this issue by removing navigate from "OnSelect" located in the button control, and placing all page navigation onto "OnSuccess" and "OnFailure" on the form itself.

Frequent Visitor

I have corrected this issue by removing navigate from "OnSelect" located in the button control, and placing all page navigation onto "OnSuccess" and "OnFailure" on the form itself. The button was navigating to a new page before the forms successfully submitted, no errors were showing.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,156)