cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gog
Helper II
Helper II

PLEASE HELP! No item to display Sharepoint data

 

Hi everyone,

I'm meeting a problem with my App.


When I launch it for the 1st time everything was Ok, but now after working with it in 1 week I face a problem.

We have 500 different ID numbers of customers in the DetailScreen. For the first 500-599 everything works great. But when we pass ID 600, problem arise. 

 

The problem is when I click on "EditButtn" whe I want to edit an already existing customer data card. Then I get my data in the Edit Form and I add som etext and change a Yes/No switch to Yes. Then I click SaveButton. Usually I navigates to the same ID that I just edited, and the new changes are saved and displayed. But now I get "No Item To Display" on the screen. And when I check the list on Sharepoint, all data is saved?!?

 

Can you help me please?

 

The OnSelect property on the Edit button is:  EditForm(EditForm1);Navigate(EditScreen1, ScreenTransition.None)
The OnSelect property on the Save button is: SubmitForm(EditForm1);Navigate(DetailScreen1, ScreenTransition.None)

 

I already tried to follow the steps in this guide: https://powerusers.microsoft.com/t5/PowerApps-Forum/No-item-to-display-sharepoint-data/td-p/59244
but it didnt work 😞

5 REPLIES 5
gog
Helper II
Helper II

Anyone can help please?

v-yamao-msft
Community Support
Community Support

Hi gog,

 

What’s your current situation? Are you still having the issue?


When you create a new item, will it return the same error message?


Do you have more than 600 items in your list? When you edit existing items before ID 599, will you get the error message?

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel

Thank you for your answer. Yes, I am having the same still.

yes, when Icreate a new item, it will return the same error message.

I have 500 items in my list. The ID number start at 501 and goes to 999. Before ID 600 (which means the first 100 ID:s) I dont get the error message.


Best regards, 
Gog

Could you help please?

 

CarlosFigueira
Power Apps
Power Apps

It's possible that when you insert or save the item, the gallery is reloaded and since the item isn't in the first page (which is loaded by the gallery), and since the Item property of the forms are set to the gallery selection, then nothing is selected and you can see that message.

 

One possible solution is to decouple the forms from the gallery selection. This way, when an item is inserted (or edited), you get the exact same item displayed properly.

 

The post at https://blogs.msdn.microsoft.com/carlosfigueira/2017/10/04/decouplingbrowsegalleryfromforms/ has detailed informatoin on how to decouple the forms. If you do that, I believe it will solve your problem.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Carousel_PP_768x460_Wave2 (1).png

2022 Release Wave 2 Plan

Power Platform release plan for the 2022 release wave 2 describes all new features releasing from October 2022 through March 2023.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Top Solution Authors
Users online (3,074)