cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
powerapps_dev
New Member

PowerApps Android - Attachments except images are not working "Something went wrong"

Hi Msft Team,

 

I've a canvas app to upload some details and attachments to an SPO custom list. The app is working fine in browsers on desktop and mobile versions in Apple and Windows environment.

 

When it comes to attaching files (Excel, PDF, Word, etc.) on the PowerApps (Google Play store latest version) on Samsung or OnePlus devices, the app throws error "Something went wrong" for the attachment card. It is allowing to upload images, but no other file can be attached.

 

Could you please point me to the resolution or if this is a known bug, let me know when the resolution is expected?

 

Thanks in advance!

11 REPLIES 11
v-micsh-msft
Community Support
Community Support

Hi @powerapps_dev,

 

Are the files very large?

Currently the attachment control could only upload files up to 10 MB in size.

For the other limits, see the reference here:

Quoted:

"

The attachment control has these limitations:

  1. Attachments are supported with SharePoint lists and CDS for Apps entities.

  2. Upload and delete functionality only work inside a form. Attachment control will look disabled when in Edit mode and not inside a form. Note that in order to save the file additions and deletions to the back end, the end user must save the form.

  3. You can only upload files up to 10 MB in size.

"

If that is not the case, could you please share your App ID & the corresponding Session ID here?

For how to find session ID, see:

Get a session ID or a canvas-app ID

 

Best regards,

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi,

 

Thank you for the response.

The attachment limitations are not the issue as all uploads are within parameters.

 

Session ID: ef76a06f-c1cc-4e43-99ce-27f8f4985546

App ID: e776fae2-304e-4037-acc5-85ac539cf6fe

 

Thank you

Hi @v-micsh-msft,

 

Any updates regarding this issue?

 

Thank you,

Regrads

Hi @powerapps-dev @v-micsh-msft

 

I have the same problem on a Samsung S8+ and a Samsung S3.

 

This has been outstanding for about 3 months - I reported the issue then.

 

Regards

 

Nigel

Hi

 

Here is my original post back in September :- https://powerusers.microsoft.com/t5/General-Discussion/using-the-Attachments-card-on-a-mobile-phone-...

 

Regards

 

Nigel

Anonymous
Not applicable

Nothing yet? I'm having the same issue. Pixel 3.

 

Hi @v-micsh-msft

 

Are there any updates to this problem?

I am working on an app for a client as the solution to their business problem, so need to know how to move forward with this issue as a matter of urgency.

 

Regards

@v-micsh-msft,

 

Session ID: b18e72dc-ab44-46e0-99b5-c3962835bf29

 

 

This is a known issue.  We have a fix for it.  The fix is not in production yet.  It should get deployed to production by early March.  Please stay tuned.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (39,730)