cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi, PowerApps Team,

 

I am using the latest PowerApps version 3.18042.20. I have a field "Item_Qty" with data type of int. I would like it to have a default  of null deliberately set. Otherwise, the value could be carried over from other records in different form. In the data card for this field, I used "" for the default instead of "ThisItem.Item_Qty".

 

This setup works out fine in the edit mode, but when I ran the app in the "Play" mode, I encountered two problems; (1) instead of null value in the field, it got a value of zero (0) showing up, and when I tried to enter a value (other than 0), it would not take it. It looked like this field would not take any input from the keyboard. This is a required field, and the form couldn't be submitted as a result.

 

In summary, the app in Edit mode works, and the app in "Play" mode does not work. This means I can create an app for myself, I can't share it with others. In the past I have had occasions that the behaviors of the app have been different between Edit and Play mode. 

 

Can you offer some help?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

OK, It seemed to be a syntax issue and how I had different commands ordered.  Working now.

View solution in original post

66 REPLIES 66
Anonymous
Not applicable

I have the same thing since last release.

 

I am using SQL Azure backend. The users are trying to edit the record & an error message is appearing "An entry is required or has an invalid value. Please correct and try again."

 

No changes have been made since release. Why has this stopped working?

Hi,

 

I just found out that the records in the edit form can't be updated, The error message is "An entry is required or has an invalid value. Please correct and try again."

 

This is a show stopper and needs to be dealt with asap!

 

 

PowerApps Team,

 

It looks like the edit problem did not show in the version v3.18041.20, and it exists  in v3.18042.20.  Can you give me the full version # for v3.18041.20 so that I can start my work using that version?

 

Is there a general way to find out the exact software release version number so that we as a customer can go back to the version that worked for us when you release a new version that has issues? This way we have some leverage in managing our risks using PowerApps.

Same issue here.  Just spent 10 hours trying to isolate the problem.  Replaced every field, replaced form, replaced data connection. No luck

 

Issue is in SharePoint Lists for me...

 

Always with editing an existing item

 

App works fine in preview mode in Web Studio but throws the error the very erratically in web player -  works sometimes but then will throw an error edit form in the web player - version 3.18042.20.  After you get the error and try to submit form again it will work...  

 

Please roll back to previous version of web player until you isolate the issue

 

Here is some info you can use to diagnose the issue

Web Player Version 3.18042.20

Session ID: b71b554a-13af-41b0-8223-5b6ec5d2d5bf

 

 

 

 

Any update on this? 

 

Still seeing the issue in the web player version 3.18042.20

 

App works fine in web Studio preview mode

 

Any update on this? 

 

Still seeing the issue in the web player version 3.18042.20

 

App works fine in web Studio preview mode

 

Anonymous
Not applicable

Any update on this issue as we are about to go live and have this issue coming up!

nope

 

just crickets...

About one month ago, PowerApps had a software release that wiped out everyone’s gallery layout, they made an emergency release about two weeks later with the release # 3.18041.20 that just fixed the previous problem. During this period, the PowerApps team gave me the exact release # (2.0.783) of the software that has been working in my apps so that I could continue my work before their fix (v3.18041.20) came out.

 

Only a few days after their v3.18041.20 release came in the v3.18042.20 in which we all experienced the update problems in the edit form. I am still not 100% sure if the update problem exists in v3.18041.20 or not.

 

Given that they release the software so frequently and their releases are so unstable, I am going to hang on the release version that works for my apps and keep my development work on that version for as long as possible. Otherwise I will be in the turmoil of the PowerApps software releases. Something worked yesterday won’t necessarily work today! You may try the same strategy by asking the PowerApps team to give you the release version that has been working for you.

 

For this problem we are having, I have not seen a PowerApps team member in the loop, not sure if they are aware of this problem.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,923)