cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Can't connect Common Data Service in non-default environment to SharePoint list

I have a PowerApp submits data to the Common Data Service in its own special environment, let's call it EnvironmentA. I wanted to write a flow to create an item in a SharePoint Online list when a record is created for that entity in the CDS. But apparently, I can't. I think this is because the PowerApp is not in the default environment. When I use the default environment, I can find the SharePoint Online list, but I can't access the CDS entity. If I switch to EnvironmentA I can't access the CDS entity. Is there any way to work around this? I would prefer not to deploy the app to the default environment. I am free to make changes to the SharePoint lists, but not sure what I can do? I don't think SharePoint has environments, so how do I make a Flow connect a CDS/PowerApps environment and a SharePoint list? 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

It is strangely working today although I have made no changes to the CDS or SharePoint environments. I'll assume this was just a random connectivity issue for Flow. I have seen others comment with similar experiences. 

View solution in original post

6 REPLIES 6
Highlighted
Community Support
Community Support

Hi @Anonymous,

 

Not all license contains the CDS in powerapps, please see:

https://powerapps.microsoft.com/en-us/tutorials/pricing-billing-skus/

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Nope, I can access and administer CDS just fine. I already built and deployed an app that uses it. I'm just trying to add this Flow to also move the data to SharePoint. I am on the PowerApps Plan 2. Any other thoughts?
Highlighted
Anonymous
Not applicable

Hmmm. I tried this in a test tenant, and it worked. I have a default environment and a separate environment for my PowerApp called MeaganTest. I created an entity in the CDS in the MeaganTest environment and then created a SharePoint list. I then created a flow in the MeaganTest environment that adds a new item to the SharePoint list. I had no trouble connecting the two, and my flow ran successfully when triggered. 

 

So this leads me to believe there is some kind of setting or environment error. Why is it on my test tenant, I can create a flow that connects to my SharePoint list and to a CDS entity in a non-default environment, but I can't on the other tenant? Any suggestions for settings to check would be appreciated. 

Highlighted

Hi @Anonymous,

 

Were you trying to trigger a flow in a PowerApps app? If so, please provide the session ID. Sorry that I'm not quite sure that I understand you issue correctly.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

It is strangely working today although I have made no changes to the CDS or SharePoint environments. I'll assume this was just a random connectivity issue for Flow. I have seen others comment with similar experiences. 

View solution in original post

Highlighted

Hi all,

 

I'm facing the exact same issue, does anyone have a clue why Flow doesn't connect to non-default CDS Environments?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (8,225)