cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Romansx
Advocate IV
Advocate IV

LookUp field not showing id

Hi everyone!

Lets initiate with the issue that i encounter...

-I have two entities: 1 entity child and 1 entity parent that i already conected in a relationship.

-In the app invoke the function "clearcollect" to save in collection both entities.

 

All is good from here.

 

The problem is that the id field wich is autogenerateddefault by the system when a new record is created is not showing when i lookup from the other connected entity (child) so not gives an "id" to resemble on to another conected Entity...

 

So I have two entities connected in CDS by lookup, but i have two collections in the app that are not related by any field....

 

Why the id of parent entity in child entity in collection is not showing???

1 ACCEPTED SOLUTION

Accepted Solutions
CWesener
Power Apps
Power Apps

Hi @Romansx - this is a known issue are team is working on resolving. Keep an eye out for updates in the coming weeks.

Thanks,
Clay.

View solution in original post

3 REPLIES 3
Lisabel0
Helper V
Helper V

I got the same result. Seems to be by design.

In CDS2.0, Primary Name of the parent is the relationship connection..Not ID

CWesener
Power Apps
Power Apps

Hi @Romansx - this is a known issue are team is working on resolving. Keep an eye out for updates in the coming weeks.

Thanks,
Clay.

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (1,903)