cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate IV
Advocate IV

LookUp field not showing id

Hi everyone!

Lets initiate with the issue that i encounter...

-I have two entities: 1 entity child and 1 entity parent that i already conected in a relationship.

-In the app invoke the function "clearcollect" to save in collection both entities.

 

All is good from here.

 

The problem is that the id field wich is autogenerateddefault by the system when a new record is created is not showing when i lookup from the other connected entity (child) so not gives an "id" to resemble on to another conected Entity...

 

So I have two entities connected in CDS by lookup, but i have two collections in the app that are not related by any field....

 

Why the id of parent entity in child entity in collection is not showing???

1 ACCEPTED SOLUTION

Accepted Solutions
Power Apps
Power Apps

Hi @Romansx - this is a known issue are team is working on resolving. Keep an eye out for updates in the coming weeks.

Thanks,
Clay.

View solution in original post

3 REPLIES 3
Helper V
Helper V

I got the same result. Seems to be by design.

In CDS2.0, Primary Name of the parent is the relationship connection..Not ID

Power Apps
Power Apps

Hi @Romansx - this is a known issue are team is working on resolving. Keep an eye out for updates in the coming weeks.

Thanks,
Clay.

View solution in original post

Helpful resources

Announcements
secondImage

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

Users online (35,202)