cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hubertg
Frequent Visitor

Content snippets on header and footer not working for a site.

Hi everyone, I'm working with portal for a week and at the same time learning D365 CE coming from FO I notice there big difference on development IDE, I'm stuck with a problem. I create two portals in one instance of CE, (customer/custom) but second portal is a mess on metadata, first thing i found is that home page relation with childs works only by name, not include portal Site. So all web pages created for custom portal were related to customer home page, i fix renaming home page and change child relation, but now I have a problem with Snippets content, on my second portal "editable snippets" it's not working, so footer and header that uses snippets content have problem, i searched on internet with no luck. I want to confirm if i'm doing something wrong, I reset, delete, re implemented the custom portal many times and always the same problem.

 

content snippet.PNG

7 REPLIES 7
OliverRodrigues
Super User
Super User

When you say you already reset the portal, did you do it via Portal Admin Center resting to the default configuration?

https://docs.microsoft.com/en-us/powerapps/maker/portals/admin/reset-portal

 

every content snippet should be linked to your web site, can you make sure they are linked to the correct website?

 

in the website record, there is a reference to Header/Footer web template, can you make sure those are being referenced to the correct records?


------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Pages Super User | MVP


Oliver Rodrigues


 

Hi Oliver

 

Yes, I reset the portal from admin,  also i delete it following all the instructions.   the content snippets are created and related to the custom site.

 

This has been a problem that help me a lot to understand metadata on portals (2 days), I checked every component and configuration on portal management for both sites.  But i don't get what is missing,  and neither I understand why the metadata of the second portal is always created with the child pages of the home as children of the customer portal home page.  I rename the customer portal homepage "HomeCP" to avoid this problem when custom portal "Home" is created.

 

content snippet 2.PNG

 

On customer portal this snippets are working OK,

 

Snippets 3 ok.PNG

 

After different things, I edit the default snippet on client admin mode and I noticed that new Snippet created was with empty language,  So i tested removing the language on default snippets and now they are working on my Site.  I'm really confused because docs says language are mandatory on snippets, also my portal is in English, i checked my user language on d365 and it's English, someone can confirm where it's the language configuration.  Also in the other site "customer portal" snippets are in english and with same user they are working ok 😕

 

Snippet OK.PNG

Site Lang.PNG

footer ok.PNG

glad it's working now

 

do you remember setting up multi-language in your portal? 

there are a few steps to achieve that:

  • enable the additional language in CDS 
  • navigate to your website record in the Portal Management App, and create a Website Language record (it should always contain at least one record)
  • there is also a default language associated to the website, make sure you have a value in there

OliverRodrigues_0-1597046125995.png

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Pages Super User | MVP


Oliver Rodrigues


 

No, Until that moment i didn't,  Only english on portal, but on my CDS i also configured spanish days ago before create the portal.

 

So i did a new Test, i set a second language "Es" on my portal and i choose as default, so with this content Snippet were created in spanish automatically and the portal seems to work with snippets in es-Es, but the navigation bar is missing now.

 

hubertg_1-1597072100067.png

 

When i return to English the problem continues, i try to remove the language from content snippets using the excel plugin for entity  but it not possible, only way it manually one by one on portal management.   

 

 

 

 

well, now that you enabled the language perhaps your weblinkset need to have the language associated 

 

go to the Portal Management App and make sure your Web Link Set has a language:

 

OliverRodrigues_0-1597091122724.png

 




If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Power Pages Super User | MVP


Oliver Rodrigues


 

Absolute disaster in metadata, I don't know why if I only create two portals without any customization, I just starting to learn but the experience have been frustrating.  All content web pages belong to custom portal are relate to customer portal root pages.

 

web pages bad.PNG

 

I don't know, but I think that custom Portal and Customer Portal are incompatible. 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

MPP IDEAS updated 768x460.png

Ideas

Discover ideas and concepts from users like you for how to use Power Pages and take your work to the next level.

Top Solution Authors
Users online (2,503)