cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
gbuhre
Level: Powered On

SubmitForm "The data source supplied to function is invalid."

This morning have been having issues loading my app if I open and close my browser a few times it finall works.   When I try and submit a new form it errors out with the following.  The data source supplied to function is invalid.  I remove the data soruce added back in and still get the same error.   I've removed the data soure then added it back with the same issues.

 

SubmitForm The data source supplied to function is invalid.

1 ACCEPTED SOLUTION

Accepted Solutions
gbuhre
Level: Powered On

Re: SubmitForm "The data source supplied to function is invalid."

I came in this morning and launch the same App with NO issues never mad any changes it's working like it should.   

View solution in original post

4 REPLIES 4
Anonymous
Not applicable

Re: SubmitForm "The data source supplied to function is invalid."

What is the data source?

Have you made an empty app and written to the data source from a form?
gbuhre
Level: Powered On

Re: SubmitForm "The data source supplied to function is invalid."

Just tested and that works.   But can't get it to work in my existing from Fiddler I'm getting HTTP/1.1 204 No Content error when trying to submit the data..   I can view the data from the app but I can not update or create new.  

Community Support Team
Community Support Team

Re: SubmitForm "The data source supplied to function is invalid."

Hi @gbuhre ,

Please refer this doc to check whether you use right way to update data:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/working-with-forms

Please try to clear your browser's cache and update it to the latest version.

If the problem still exits, try to recreate your app.

 

Best regards,

Community Support Team _ Phoebe Liu

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
gbuhre
Level: Powered On

Re: SubmitForm "The data source supplied to function is invalid."

I came in this morning and launch the same App with NO issues never mad any changes it's working like it should.   

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (6,196)